แจ้งเตือน PHP 5 หมดอายุซัพพอร์ตสิ้นปีนี้, เว็บไซต์ PHP ยังใช้งานอยู่ถึง 74.6%

Submitted by admin December 27, 2018

โครงการ PHP เตรียมเลิกซัพพอร์ต PHP 5 ตัวสุดท้ายคือรุ่น 5.6 หลังจากขยายเวลาซัพพอร์ตมาหนึ่งปี ตอนนี้เหลืออีกเพียง 6 วันก็จะไม่มีการซัพพอร์ต PHP 5.6 อีกต่อไปแล้ว นับเป็นจุดสิ้นสุดของ PHP 5.x ที่ออกมาตั้งแต่ปี 2004 หรือ 14 ปีมาแล้ว

ความน่ากังวลคือแม้จะแจ้งเตือนกันมานาน แต่เว็บที่ใช้ PHP จำนวนมากยังคงไม่ได้อัพเกรด โดยรายงานสำรวจของ W3Techs ระบุว่าเว็บที่ใช้ PHP ยังคงใช้เวอร์ชั่น 5.x อยู่ถึง 74.6% และอัพเกรดเป็น PHP 7.x เพียง 24.8% เท่านั้น

สำหรับผู้ใช้ลินุกซ์บางรุ่นที่ผู้ผลิตซัพพอร์ตระยะยาวและเลือกใช้ PHP รุ่นที่มากับตัวดิสโทรเองก็อาจจะได้รับซัพพอร์ตต่อไปอีกระยะหนึ่ง แต่แพตช์ก็มักจะจำกัดมาก (ขึ้นกับนโยบายของแต่ละดิสโทร) ยังไงเสียก็ควรอัพเดตไปยังเวอร์ชั่นใหม่ๆ ที่ยังมีการซัพพอร์ต

ที่มา - PHPW3Techs, Blognone

 

 

LEAVE COMMENT

© Developed by CommerceLab

Please wait...